My Other Blog

What's a Wreck?

A Cake Wreck is any cake that is unintentionally sad, silly, creepy, inappropriate - you name it. A Wreck is not necessarily a poorly-made cake; it's simply one I find funny, for any of a number of reasons. Anyone who has ever smeared frosting on a baked good has made a Wreck at one time or another, so I'm not here to vilify decorators: Cake Wrecks is just about finding the funny in unexpected, sugar-filled places.

Now, don't you have a photo you want to send me? ;)

- Jen

We...... Need Your Help!

Hi Guys!

We've been tweaking some things here on the site recently in an attempt to improve load time and reduce glitches, but we're afraid this tweaking may have angered the tiki gods/gremlins/Blogger bogeys. And since every web browser presents a whole new fun set of complications, testing them all out is difficult.

That's where you come in.

Please, tell us in the comments if you had any problems loading, viewing or interacting with the site today. (This includes any RSS feed wonkiness.) In addition, if you don't mind, please let us know if your virus software or filters are blocking the site or any of the pictures. And remember, this is for posterity so, be honest.

Thanks, everyone!

Update: There are no images on this post and the link at the bottom of this post for Help for Haiti should not have an image either.

'Nother Update: Hey, Internet Explorer users! First of all, you really should be using a different browser. [grin] However, we know you don't all have a choice in the matter, so we're still working on getting all the IE kinks worked out. We'll update again when we've made more progress, but please be patient (and maybe try Firefox) in the mean time. Thanks!

« Nothing To See Here | Main | Evolution of a Wreck »

Reader Comments (371)

Well, the we... need your help post showed up @ 11 pm on my Google RSS feed. I saw the post from Tuesday earlier and it came up fine on the same feed on my droid.

June 2, 2010 | Unregistered CommenterNicky

I'm on a Macbook Pro with Safari and have had no problems at all ever with this site. I'll let you know if that changes.

June 2, 2010 | Unregistered CommenterStephanie McGee

On a Mac using Firefox...looking good!

June 2, 2010 | Unregistered Commenterliz

All looks good in Google Chrome with Vipre Antivirus/Firewall...stuff.

(Two movie references in one short post - excellent coverage!)

June 2, 2010 | Unregistered CommenterAnnette

The site looks fine for me running a nightly build of Chromium. You should check out browsershots. It is a very neat tool that takes a bunch of screenshots of your site on different browsers and OSs.

June 2, 2010 | Unregistered CommenterZac

That Princess Bride reference was a bit slow to load for me. But that's more of a user problem than a tech problem.

June 2, 2010 | Unregistered CommenterZachary

The site took a wee bit longer than usual to load on Firefox..but then again that could just be my internet connection.

Like the new CW billboard!

June 2, 2010 | Unregistered CommenterASM

Macbook with Safari, everything looks great. RSS working too. Love this site!

June 2, 2010 | Unregistered CommenterMrs. Posey

Im using firefox on an HP laptop and have never had any problems :)


June 2, 2010 | Unregistered CommenterAngelique

Using Firefox on a Mac here; reading from China, and using Google's RSS feed.

No problems, but most blogger blog don't show up in China (a lot of us foreigners use tunnels to 'break' through the Great Firewall). Without my tunnel, your RSS entries come up as text with no pictures, the blog itself is totally inaccessible.

However, through the tunnel, no problems!

June 2, 2010 | Unregistered Commenterdaydreamwanderer

Browser: Firefox
System: XP

Looks good to me. Loaded quickly and no problems.

June 2, 2010 | Unregistered CommenterComatose_Angel

I can't remember ever having a problem on your site.

This posted on my Google RSS feed at 10:45pm. I'm using Firefox with Norton360.

June 2, 2010 | Unregistered CommenterJanet

Running Chrome on Windows XP and everything looks great!

June 2, 2010 | Unregistered CommenterAgent Beryllium

we have windows vista, and use internet explorer. your post showed up in my blog list (right here on blogger), and everything looks/loaded totally fine. <3

June 2, 2010 | Unregistered Commenterlauren ♥

Looks fine to me! I'm on a PC, using Firefox and Norton antivirus software. And in Uganda (for now)!

I could see this post in my Google reader too!

June 2, 2010 | Unregistered CommenterS.

HP laptop with Windows 7, using firefox. Everything appears to be in working order.

June 2, 2010 | Unregistered CommenterReading Rachel

I've never had a problem with the site before now, but today it was very slow to load (the last time I checked - the memorial day post - was fine). I'm using IE7 - don't hurt me, I'm at work and I don't have a choice of browser! But yes, slow to load, and slow scrolling even after it loaded.

June 2, 2010 | Unregistered CommenterTrowzers

Post showed up for me around 11 on RSS for me as well. Went to the site using Chrome and had no problems with the front page or with the historical content. Can't wait to see you in La Jolla!

June 2, 2010 | Unregistered Commenterbriwei

Macbook Pro running Chrome. Took a little longer than usual to load but no actual problems.

June 2, 2010 | Unregistered CommenterShli

Using Firefox on Windows XP (laptop) and viewing via Google Reader. Everything looks great.

June 2, 2010 | Unregistered Commenterkaliseviltwin

Working with Firefox on Windows XP. Site looks good!

Posts come up fine on my rss as well (Google Reader)

Keep up the fantastic work!
(and do a european tour sometime....please??)

June 2, 2010 | Unregistered CommenterCharly

I'm using Windows 7 and Google Chrome (latest version), and Google Reader on my homepage.

It all looks fine.

I do find the white text on blue less easy to read than black on white but that's just a personal preference. It all loads fine.

June 2, 2010 | Unregistered Commenterfairyhedgehog

Just got notice of this post to my Google reading list. Nothing's been wonky at all for me. I'm using Google Chrome & Windows Vista.

June 2, 2010 | Unregistered CommenterLarissa

I use Firefox and view your site primarily through Google Reader. I've never had a problem viewing your posts(thank goodness).

Just a quick note, I wanted to say thank you for making your full posts available on RSS. A lot of sites make you click through to their website. Sometimes that's just not optimal, say when you're using your phone to read stuff. Anyhow, thanks for the laughs and keep on being awesome!

June 2, 2010 | Unregistered CommenterDarcy Darlin'

Mine has been ok and I use a PC with Firefox and a Macbook pro with Firefox and with Safari. Thanks for the great stuff!

June 2, 2010 | Unregistered CommenterMonica

I've had some issues. All cake pictures look really really ugly.

June 2, 2010 | Unregistered CommenterHMCIV

I'm runnin windows on a laptop with okay internet and Chrome and its lookin' good!

June 2, 2010 | Unregistered CommenterJordan

No problems in Europe -- Yahoo RSS feed was fine, page loaded normally.

Running Firefox on XP with AVG.

June 2, 2010 | Unregistered CommenterAnonymous

Looks great on Google Reader in Firefox at my work PC and my home Mac. Thanks for brightening my day!

June 2, 2010 | Unregistered CommenterLovely Cat

I'm on Mozilla Firefox and reading this overseas--and our national Internet company is suffering crazy-slow run times right now--but this thing is loading faster than I've ever seen it, and all the pix check out fine. Also getting the RSS as usual. So, awesome! Whatever you're doing, keep doing it!

June 2, 2010 | Unregistered Commentersnoekbrown

Mac OSX, Firefox, loaded way faster than usual and I wondered why. Read the post and knew why. Yeah!!

My faves on this site are the before and afters: what it was supposed to be and what was delivered. After that are the ones were it looks decent, readable, not too much flotsam, but is inherently wrong, like "one number dad." So you could deliver them and be really proud of your work, and get lots of exasperated looks and not know why.

Win cakes are also cool. Down with purses and shoes though. They are boring.

June 2, 2010 | Unregistered CommenterAnonymous

No troubles. Firefox 3.5.9, Linux Ubuntu, here from a feed which showed up obviously considerably later than some, but no slowness, everything loads fine.

June 2, 2010 | Unregistered CommenterLara

I used Chrome and had absolutely no problems.

June 2, 2010 | Unregistered CommenterLeah


Ahem. That said, I didn't have any issues. I'm running Windows Vista and using Firefox 3.0.19, had no issues with the site loading, my RSS feed showed up fine, and my adblockers/virus scanners/etc don't seem to be having any issues.

June 2, 2010 | Unregistered Commentermoonlight69

I didn't have problems with either Safari or Firefox (on a Mac). Looks good!

on windows xp using firefox and this was the fastest this site has ever loaded! yay!!

June 2, 2010 | Unregistered Commenterevil cake lady

Windows XP, Firefox, Google Reader (4pm) on a Toshi laptop in Sydney Australia. Not an issue to be had!

June 2, 2010 | Unregistered CommenterMissKikkiKat

Microsoft windows XP, Firefox, RSS feed in bookmark toolbar, A Okay.

The only issue I had was a couple days ago when all of my RSS feeds suddenly showed up as unread.

June 2, 2010 | Unregistered CommenterE.M. Green

I'm a PC with Vista and IE8 -- no probs whatsoever.

June 2, 2010 | Unregistered CommenterIslandPearl

I'm not sure when/if you recently changed the font of your "Cake Wrecks" header, but I jut noticed that it sort of looks like it's made from a CCC (ptooey!).

Not sure if it was inentional or not :-)

LOVE your site, btw!

June 2, 2010 | Unregistered CommenterJyl

First time I loaded the page, it didn't show any posts. So then I refreshed and they were there. Using IE and running windows vista.

June 2, 2010 | Unregistered CommenterSarah

Firefox is working great for me today!

In fact, I'd begun to assume the strange new formatting for the comment boxes that was displaying was intentional... >_>

Bonus cookies for the PB reference. That's one of my favorites. :)

June 2, 2010 | Unregistered Commentershadow

No trouble loading on either Google Reader or straight from Blogger via Firefox.

June 2, 2010 | Unregistered CommenterXoynx

Using Firefox, the site took forever to load! But at least it loaded this time :)

June 2, 2010 | Unregistered CommenterAnonymous

I'm on a MacBook, using Firefox 3.6., and Google Reader to access my blog feeds -- no problems here.

June 2, 2010 | Unregistered Commenter--K.

Using Firefox 3.6.3 on Windows Vista. On Sunday and Monday morning when I checked the site I couldn't see any of the old comments, but I thought it was a blogspot problem rather than a browser problem (did you guys just get your own domain or something?) But the comments all came back and everything seems fine now.


June 2, 2010 | Unregistered CommentertheangelJean

I'm on Firefox and Windows 7.
There's a very large space on the left of the posts - if the individual post "squares" should align with the header, they don't.

Good luck with the updates!

June 2, 2010 | Unregistered CommenterAnonymous

Everything OK using Google Reader and Firefox 3.6 on Windows 7 (i do admit I have Adblock Plus installed, so no ads for me).

Great loading time btw!


PS: my wv is "ingst" and there's no cake in this post :( well, maybe that's a good thing, still not sure if i'd dare try eating a wreck :D

June 2, 2010 | Unregistered CommenterAnonymous

My RSS was fine. No issues with Safari on my Macbook Pro.

June 2, 2010 | Unregistered CommenterAnonymous

Sitting i Denmark with Opera and Avira AntiVir - no problems what so ever :-D

June 2, 2010 | Unregistered CommenterKlidmoster

PostPost a New Comment

Enter your information below to add a new comment.
Author Email (optional):
Author URL (optional):
Some HTML allowed: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <code> <em> <i> <strike> <strong>